Yalo
    e-mail
    internet accelerators
    internet access
    internet and phone call
    web hosting
    storage space
    url redirection
    internet call waiting
    free sms
    nota bene
 

How to configure Cisco - Linux GRE tunnel

 

Cisco 851. CiscoIOS version 12.4. Linux Slackware 12.0

GRE over IP tunnel Cisco - Linux

Cisco end


show conf 
!
interface Tunnel1
 ip address 10.10.10.9 255.255.255.252
 tunnel source FastEthernet4
 tunnel destination 193.193.193.193
!
interface FastEthernet4
 ip address 191.191.191.191 255.255.255.0
!
interface Vlan1
 ip address 10.3.0.1 255.255.255.0
!
ip route 10.2.0.0 255.255.255.0 Tunnel1
!

Linux end


# ifconfig eth0 193.193.193.193 netmask 255.255.255.0 

# ifconfig eth1 10.2.0.1 netmask 255.255.255.0 

# ip tunnel add my_tunnel mode gre remote 191.191.191.191 local 193.193.193.193 ttl 255 
# ip addr add 10.10.10.10/30 dev my_tunnel
# ip link set dev my_tunnel up 

# ip route add 10.3.0.0/24 dev my_tunnel

# ip tunnel
gre0: gre/ip  remote any  local any  ttl inherit  nopmtudisc
my_tunnel: gre/ip  remote 191.191.191.191  local 193.193.193.193  ttl 255