Yalo
    e-mail
    internet accelerators
    internet access
    internet and phone call
    web hosting
    storage space
    url redirection
    internet call waiting
    free sms
    nota bene
 

How to configure PPPoE on Cisco router

 

Cisco 851. CiscoIOS version 12.4.

PPPoE dial-up. NAT on PPP interface


show conf 
!
vpdn-group 1
 request-dialin
  protocol pppoe
 l2tp tunnel receive-window 128
!
ip route 0.0.0.0 0.0.0.0 Dialer1 permanent
!
ip nat inside source list 101 interface Dialer1 overload
!
interface Dialer1
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip tcp adjust-mss 1452
 no ip mroute-cache
 dialer pool 1
 dialer-group 1
 no keepalive
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname USERNAME
 ppp chap password 7 ENCRYPTEDPASSWORD
 ppp pap sent-username USERNAME password 7 ENCRYPTEDPASSWORD
 no ppp pap wait
 ppp ipcp dns request
!
interface FastEthernet4
 no ip address
 ip virtual-reassembly
 duplex auto
 speed auto
 pppoe enable group 1
 pppoe-client dial-pool-number 1
!
interface Vlan1
 ip address 10.10.10.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
access-list 101 permit ip 10.10.10.0 0.0.0.255 any
!